Configuration

(Difference between revisions)
Jump to: navigation, search
(Created page with "Most of Stellarium's configuration is done using the configuration window and the view window. To open the configuration window, click the button on the left side toolbar or pre...")
 
(23 intermediate revisions by 3 users not shown)
Line 1: Line 1:
 +
{{ActualVersion|0.12.3}}
 
Most of Stellarium's configuration is done using the configuration window and the view window. To open the configuration window, click the  button on the left side toolbar or press F2. To open the view window click the  button if the left side toolbar or press F4.
 
Most of Stellarium's configuration is done using the configuration window and the view window. To open the configuration window, click the  button on the left side toolbar or press F2. To open the view window click the  button if the left side toolbar or press F4.
  
Some options may only be configured by editing the configuration file. See section '''configfile''' for more details.
+
Some options may only be configured by editing the configuration file. See [[Advanced Use#The Main Configuration File| configuration file]] for more details.
  
 
==Setting the Date and Time==
 
==Setting the Date and Time==
  
http://stellarium.org/wikiimg/UserManual/datetime.png
+
http://stellarium.org/wikiimg/UserManual/date_and_time_dialog.png
  
In addition to the time rate control buttons on the main toolbar, you can use the date and time window to set the simulation time (figure [fig:datetime]). The values for year, month, day, hour, minutes and seconds may be modified by typing new values, by clicking the up and down arrows above and below the values, and by using the mouse wheel.
+
In addition to the time rate control buttons on the main toolbar, you can use the date and time window to set the simulation time. The values for year, month, day, hour, minutes and seconds may be modified by typing new values, by clicking the up and down arrows above and below the values, and by using the mouse wheel.
  
 
==Setting Your Location==
 
==Setting Your Location==
  
http://stellarium.org/wikiimg/UserManual/location.png
+
http://stellarium.org/wikiimg/UserManual/location_dialog.png
  
 
The positions of the stars in the sky is dependent on your location on Earth (or other planet) as well as the time and date. For Stellarium to show accurately what is (or will be/was) in the sky, you must tell it where you are. You only need to do this once - Stellarium can save your location so you won't need to set it again until you move.
 
The positions of the stars in the sky is dependent on your location on Earth (or other planet) as well as the time and date. For Stellarium to show accurately what is (or will be/was) in the sky, you must tell it where you are. You only need to do this once - Stellarium can save your location so you won't need to set it again until you move.
  
To set your location, press F6 to open the location window (figure [fig:location]). There are a few ways you can set your location:
+
To set your location, press F6 to open the location window. There are a few ways you can set your location:
 
# Just click on the map.
 
# Just click on the map.
 
# Search for a city where you live using the search edit box at the top right of the window, and select the right city from the list.
 
# Search for a city where you live using the search edit box at the top right of the window, and select the right city from the list.
Line 25: Line 26:
 
The configuration window contains general program settings, and many other settings which do not concern specific display options.
 
The configuration window contains general program settings, and many other settings which do not concern specific display options.
  
http://stellarium.org/wikiimg/UserManual/confwinmaintab.png
+
http://barry.sarcasmogerdes.com/stellarium/config_dialog_main_tab.png
  
 
The Main tab in the configuration window provides controls for changing the program language, how much information is shown about selected sky objects, and provides a button for saving the current program configuration.
 
The Main tab in the configuration window provides controls for changing the program language, how much information is shown about selected sky objects, and provides a button for saving the current program configuration.
  
http://stellarium.org/wikiimg/UserManual/confwinnavigationtab.png
+
http://stellarium.org/wikiimg/UserManual/config_dialog_info_tab.png
 +
 
 +
The Information tab allows you to set the type and amount of information displayed on a selected object.
 +
 
 +
• Ticking or unticking the relevant boxes will control this.
 +
 
 +
• The information displays in various colours depending on the type and level of the stored data
 +
 
 +
http://barry.sarcasmogerdes.com/stellarium/config_dialog_navigation_tab.png
  
 
The Navigation tab allows for enabling/disabling of keyboard shortcuts for panning and zooming the main view, and also how to specify what simulation time should be used when the program starts:
 
The Navigation tab allows for enabling/disabling of keyboard shortcuts for panning and zooming the main view, and also how to specify what simulation time should be used when the program starts:
Line 36: Line 45:
 
* When “Other” is selected, some fixed time can be chosen which will be used every time Stellarium starts.
 
* When “Other” is selected, some fixed time can be chosen which will be used every time Stellarium starts.
  
http://stellarium.org/wikiimg/UserManual/confwintooltab.png
+
http://barry.sarcasmogerdes.com/stellarium/config_dialog_tools_tab.png
  
 
The Tools tab of the configuration window contains miscellaneous utility features:
 
The Tools tab of the configuration window contains miscellaneous utility features:
Line 44: Line 53:
 
* '''Gravity labels''' This option makes labels of objects in the main view align with the nearest horizon. This means that labels projected onto a dome are always alighned properly.
 
* '''Gravity labels''' This option makes labels of objects in the main view align with the nearest horizon. This means that labels projected onto a dome are always alighned properly.
 
* '''Auto zoom out returns to initial field of view''' When enabled, this option changes the behaviour of the zoom out key (\) so that it resets the initial direction of view in addition to the field of view.
 
* '''Auto zoom out returns to initial field of view''' When enabled, this option changes the behaviour of the zoom out key (\) so that it resets the initial direction of view in addition to the field of view.
 +
 +
http://stellarium.org/wikiimg/UserManual/config_dialog_scripts_tab.png
 +
 +
The Scripts tab allows the selection of pre-assembled scripts bundled with stellarium that can be run. This list can be expanded in your user area with your own scripts as required.:
 +
 +
• When a scipt is selected it can be run by pressing the arrow button and stopped with the stop button. With some scripts the stop button is inhibited until the script is finished.
 +
 +
• Scripts that use sound will need a version of stellarium compiled at compile time with sound enabled. It must be pointed out here that sound when enabled depends on the sound capabilities of you computer plarform and may not work..
 +
 +
• Scripts that contain Video clips will need a suitable video player that enabled on tour computer..
 +
 +
http://stellarium.org/wikiimg/UserManual/config_dialog_plugins_tabs.png
 +
 +
The Plugins tab. Plug ins need to be enabled at start up to be available as shown on the bar. This allows for the selection of the plugins that you wish to be enabled at this time:
  
 
==The View Settings Window==
 
==The View Settings Window==
Line 50: Line 73:
 
===Sky Tab===
 
===Sky Tab===
  
http://stellarium.org/wikiimg/UserManual/viewwinskytab.png
+
http://barry.sarcasmogerdes.com/stellarium/view_dialog_sky_tab.png
  
 
The Sky tab of the View window[fig:viewwinskytab] contains settings for changing the general appearane of the main sky view. Some hightlights:
 
The Sky tab of the View window[fig:viewwinskytab] contains settings for changing the general appearane of the main sky view. Some hightlights:
Line 57: Line 80:
 
* '''Twinkle''' controls how much the stars twinkle.
 
* '''Twinkle''' controls how much the stars twinkle.
 
* '''Dynamic eye adaptation''' When enabled this feature reduces the brightness of faint objects when a bright object is in the field of view. This simulates how the eye can be dazzled by a bright object such as the moon, making it harder to see faint stars and galaxies.
 
* '''Dynamic eye adaptation''' When enabled this feature reduces the brightness of faint objects when a bright object is in the field of view. This simulates how the eye can be dazzled by a bright object such as the moon, making it harder to see faint stars and galaxies.
* '''Light pollution''' In urban and suburban areas, the sky is brightned by terrestrial light pollution reflected in the atmophere. Stellarium simulates light pollution and is calibrated to the ''Bortle Dark Sky Scale'' where 1 means a good dark sky, and 9 is a very badly light-polluted sky. See section [sub:lightpollution] for more information.
+
* '''Light pollution''' In urban and suburban areas, the sky is brightned by terrestrial light pollution reflected in the atmophere. Stellarium simulates light pollution and is calibrated to the ''Bortle Dark Sky Scale'' where 1 means a good dark sky, and 9 is a very badly light-polluted sky. See [[Advanced Use#Light Pollution|Light Pollution]] for more information.
 
* '''Planets and satellites''' this group of options lets you turn on and off various features related to the planets. Simulation of light speed will give more precise positions for planetary bodies which move rapidly against backround stars (e.g. the moons of Jupiter). The ''Scale Moon'' option will increase the apparent size of the moon in the sky, which can be nice for wide field of view shots.
 
* '''Planets and satellites''' this group of options lets you turn on and off various features related to the planets. Simulation of light speed will give more precise positions for planetary bodies which move rapidly against backround stars (e.g. the moons of Jupiter). The ''Scale Moon'' option will increase the apparent size of the moon in the sky, which can be nice for wide field of view shots.
 
* '''Labels and markers''' you can independantly change the amount of labels displayed for planets, stars and nebuulae. The further to the right the sliders are set, the more labels you will see. Note that more labels will also appear as you zoom in.
 
* '''Labels and markers''' you can independantly change the amount of labels displayed for planets, stars and nebuulae. The further to the right the sliders are set, the more labels you will see. Note that more labels will also appear as you zoom in.
 
* '''Shooting stars''' Stellarium has a simple meteor simulation option. This setting controls how many shooting stars will be shown. Note that shooting stars are only visible when the time rate is 1, and might not be visiable at some times of day. Meteor showers are not currently simulated.
 
* '''Shooting stars''' Stellarium has a simple meteor simulation option. This setting controls how many shooting stars will be shown. Note that shooting stars are only visible when the time rate is 1, and might not be visiable at some times of day. Meteor showers are not currently simulated.
 
http://stellarium.org/wikiimg/UserManual/viewwinmarkingstab.png
 
  
 
===Marking Tab===
 
===Marking Tab===
 +
 +
http://stellarium.org/wikiimg/UserManual/view_dialog_markings_tab.png
 +
 
The Markings tab of the View window controls the following features:
 
The Markings tab of the View window controls the following features:
 
* '''Celestial sphere''' this group of options makes it possible to plot various grids and lines in the main view.
 
* '''Celestial sphere''' this group of options makes it possible to plot various grids and lines in the main view.
Line 71: Line 95:
 
** '''cylinder''' The full name of this projection mode is ''cylindrical equidistant projection''. The maximum field of view in this mode is 233°
 
** '''cylinder''' The full name of this projection mode is ''cylindrical equidistant projection''. The maximum field of view in this mode is 233°
 
** '''equal area''' The full name of this projection method is, ''Lambert azimuthal equal-area projection''. The maximum field of view is 360°.
 
** '''equal area''' The full name of this projection method is, ''Lambert azimuthal equal-area projection''. The maximum field of view is 360°.
** ''fisheye'' Stellarium draws the sky using ''azimuthal equidistant projection''. In fish-eye projection, straight lines become curves when they appear a large angular distance from the centre of the field of view (like the distortions seen with very wide angle camera lenses). This is more pronounced as the user zooms out. The maximum field of view in this mode is 180°
+
** '''fish-eye''' Stellarium draws the sky using ''azimuthal equidistant projection''. In fish-eye projection, straight lines become curves when they appear a large angular distance from the centre of the field of view (like the distortions seen with very wide angle camera lenses). This is more pronounced as the user zooms out. The maximum field of view in this mode is 180°
 
** '''Hammer-Aitoff''' The Hammer projection is an equal-area map projection, described by Ernst Hammer in 1892 and directly inspired by the Aitoff projection. The maximum field of view in this mode is 360°.
 
** '''Hammer-Aitoff''' The Hammer projection is an equal-area map projection, described by Ernst Hammer in 1892 and directly inspired by the Aitoff projection. The maximum field of view in this mode is 360°.
 
** '''mercator''' Mercator projection preserves the angles between objects, and the scale around an object the same in all directions. The maximum field of view in this mode is 233°.
 
** '''mercator''' Mercator projection preserves the angles between objects, and the scale around an object the same in all directions. The maximum field of view in this mode is 233°.
Line 77: Line 101:
 
** '''perspective''' Perspective projection keeps the horizon a straight line. The maximum field of view is 150°. The mathematical name for this projection method is ''gnomonic projection''.
 
** '''perspective''' Perspective projection keeps the horizon a straight line. The maximum field of view is 150°. The mathematical name for this projection method is ''gnomonic projection''.
 
** '''stereographic''' This mode is similar to fish-eye projection mode. The maximum field of view in this mode is 235°.
 
** '''stereographic''' This mode is similar to fish-eye projection mode. The maximum field of view in this mode is 235°.
 
http://stellarium.org/wikiimg/UserManual/viewwinlandscapetab.png
 
  
 
===Landscape Tab===
 
===Landscape Tab===
The Landscape tab of the View window controls the landscape graphics (ground). To change the landscape graphics, select a landscape from the list on the left side of the window. A description of the ladscape will be shown on the right.
+
 
 +
http://stellarium.org/wikiimg/UserManual/view_dialog_landscape_tab.png
 +
 
 +
The Landscape tab of the View window controls the landscape graphics (ground). To change the landscape graphics, select a landscape from the list on the left side of the window. A description of the landscape will be shown on the right.
  
 
Note that while landscape can include information about where the landscape graphics were taken (planet, longitude, latitude and altitude), this location does not have to be the same as the location selected in the Location window, although you can set up Stellarium such that selection of a new landscape will alter the location for you.
 
Note that while landscape can include information about where the landscape graphics were taken (planet, longitude, latitude and altitude), this location does not have to be the same as the location selected in the Location window, although you can set up Stellarium such that selection of a new landscape will alter the location for you.
Line 92: Line 117:
  
 
===Starlore Tab===
 
===Starlore Tab===
 +
 +
http://stellarium.org/wikiimg/UserManual/view_dialog_starlore_tab.png
 +
 
The Starlore tab of the View window controls what culture's constellations and bright star names will be used in the main display. Some cultures have constellation art (Western and Inuit), and the rest do not.
 
The Starlore tab of the View window controls what culture's constellations and bright star names will be used in the main display. Some cultures have constellation art (Western and Inuit), and the rest do not.
  
http://stellarium.org/wikiimg/UserManual/viewwinstarloretab.png
+
{{Template:LRCNavigation|Interface Guide|Stellarium User Guide|Advanced Use}}
  
 
[[Category:Stellarium User Guide]]
 
[[Category:Stellarium User Guide]]

Revision as of 17:44, 18 August 2013

Information is actual for version 0.12.3

Most of Stellarium's configuration is done using the configuration window and the view window. To open the configuration window, click the button on the left side toolbar or press F2. To open the view window click the button if the left side toolbar or press F4.

Some options may only be configured by editing the configuration file. See configuration file for more details.

Contents

Setting the Date and Time

date_and_time_dialog.png

In addition to the time rate control buttons on the main toolbar, you can use the date and time window to set the simulation time. The values for year, month, day, hour, minutes and seconds may be modified by typing new values, by clicking the up and down arrows above and below the values, and by using the mouse wheel.

Setting Your Location

location_dialog.png

The positions of the stars in the sky is dependent on your location on Earth (or other planet) as well as the time and date. For Stellarium to show accurately what is (or will be/was) in the sky, you must tell it where you are. You only need to do this once - Stellarium can save your location so you won't need to set it again until you move.

To set your location, press F6 to open the location window. There are a few ways you can set your location:

  1. Just click on the map.
  2. Search for a city where you live using the search edit box at the top right of the window, and select the right city from the list.
  3. Enter a new location using the longitude, latitude and other data.

Once you're happy that the location is set correctly, click on the “use as default” checkbox, and close the location window.

The Configuration Window

The configuration window contains general program settings, and many other settings which do not concern specific display options.

config_dialog_main_tab.png

The Main tab in the configuration window provides controls for changing the program language, how much information is shown about selected sky objects, and provides a button for saving the current program configuration.

config_dialog_info_tab.png

The Information tab allows you to set the type and amount of information displayed on a selected object.

• Ticking or unticking the relevant boxes will control this.

• The information displays in various colours depending on the type and level of the stored data

config_dialog_navigation_tab.png

The Navigation tab allows for enabling/disabling of keyboard shortcuts for panning and zooming the main view, and also how to specify what simulation time should be used when the program starts:

  • When “Syetem date and time” is selected, Stellarium will start with the simulation time equal to the operating system clock.
  • When “System date at” is selected, Stellarium will start with the same date as the operating system clock, but the time will be fixed at the specified value. This is a useful setting for those people who use Stellarium during the day to plan observing sessions for the upcoming evening.
  • When “Other” is selected, some fixed time can be chosen which will be used every time Stellarium starts.

config_dialog_tools_tab.png

The Tools tab of the configuration window contains miscellaneous utility features:

  • Show flip buttons When enabled, two buttons will be added to the main tool-bar which allow the main view to be mirrored in the vertical and horizontal directions. This is useful when observing through telecopes which may cause the image to be mirrored.
  • Spheric mirror distortion This option pre-warps the main view such that it may be projected onto a spherical mirror using a projector. The resulting image will be refected up from the spherical mirror in such a way that it may be shone onto a small planetarium dome, making a cheap planetarium projection system.
  • Disc viewport This option limits masks the main view producing the effect of a telescope eyepiece. It is also useful when projecting Stellarium's output with a fish-eye lens planetarium projector.
  • Gravity labels This option makes labels of objects in the main view align with the nearest horizon. This means that labels projected onto a dome are always alighned properly.
  • Auto zoom out returns to initial field of view When enabled, this option changes the behaviour of the zoom out key (\) so that it resets the initial direction of view in addition to the field of view.

config_dialog_scripts_tab.png

The Scripts tab allows the selection of pre-assembled scripts bundled with stellarium that can be run. This list can be expanded in your user area with your own scripts as required.:

• When a scipt is selected it can be run by pressing the arrow button and stopped with the stop button. With some scripts the stop button is inhibited until the script is finished.

• Scripts that use sound will need a version of stellarium compiled at compile time with sound enabled. It must be pointed out here that sound when enabled depends on the sound capabilities of you computer plarform and may not work..

• Scripts that contain Video clips will need a suitable video player that enabled on tour computer..

config_dialog_plugins_tabs.png

The Plugins tab. Plug ins need to be enabled at start up to be available as shown on the bar. This allows for the selection of the plugins that you wish to be enabled at this time:

The View Settings Window

The View settings window controls many display features of Stellarium which are not available via the main toolbar.

Sky Tab

view_dialog_sky_tab.png

The Sky tab of the View window[fig:viewwinskytab] contains settings for changing the general appearane of the main sky view. Some hightlights:

  • Absolute scale is the size of stars as rendered by Stellarium. If you increase this value, all stars will appear larger than before.
  • Relative scale determines the difference in size of bright stars compared to faint stars. Values higher than 1.00 will make the brightest stars appear much larger than they do in the sky. This is useful for creating star charts, or when learning the basic constellations.
  • Twinkle controls how much the stars twinkle.
  • Dynamic eye adaptation When enabled this feature reduces the brightness of faint objects when a bright object is in the field of view. This simulates how the eye can be dazzled by a bright object such as the moon, making it harder to see faint stars and galaxies.
  • Light pollution In urban and suburban areas, the sky is brightned by terrestrial light pollution reflected in the atmophere. Stellarium simulates light pollution and is calibrated to the Bortle Dark Sky Scale where 1 means a good dark sky, and 9 is a very badly light-polluted sky. See Light Pollution for more information.
  • Planets and satellites this group of options lets you turn on and off various features related to the planets. Simulation of light speed will give more precise positions for planetary bodies which move rapidly against backround stars (e.g. the moons of Jupiter). The Scale Moon option will increase the apparent size of the moon in the sky, which can be nice for wide field of view shots.
  • Labels and markers you can independantly change the amount of labels displayed for planets, stars and nebuulae. The further to the right the sliders are set, the more labels you will see. Note that more labels will also appear as you zoom in.
  • Shooting stars Stellarium has a simple meteor simulation option. This setting controls how many shooting stars will be shown. Note that shooting stars are only visible when the time rate is 1, and might not be visiable at some times of day. Meteor showers are not currently simulated.

Marking Tab

view_dialog_markings_tab.png

The Markings tab of the View window controls the following features:

  • Celestial sphere this group of options makes it possible to plot various grids and lines in the main view.
  • Constellations these controls let you turn on and off constellation lines, names, art and boundaries, and control the brightness of the constellation artwork.
  • Projection Selecting items in this list changes the projection method which Stellarium uses to draw the sky. Options are:
    • cylinder The full name of this projection mode is cylindrical equidistant projection. The maximum field of view in this mode is 233°
    • equal area The full name of this projection method is, Lambert azimuthal equal-area projection. The maximum field of view is 360°.
    • fish-eye Stellarium draws the sky using azimuthal equidistant projection. In fish-eye projection, straight lines become curves when they appear a large angular distance from the centre of the field of view (like the distortions seen with very wide angle camera lenses). This is more pronounced as the user zooms out. The maximum field of view in this mode is 180°
    • Hammer-Aitoff The Hammer projection is an equal-area map projection, described by Ernst Hammer in 1892 and directly inspired by the Aitoff projection. The maximum field of view in this mode is 360°.
    • mercator Mercator projection preserves the angles between objects, and the scale around an object the same in all directions. The maximum field of view in this mode is 233°.
    • orthographic Orthographic projection is related to perspective projection, but the point of perspective is set to an infinite distance. The maximum field of view is 180°.
    • perspective Perspective projection keeps the horizon a straight line. The maximum field of view is 150°. The mathematical name for this projection method is gnomonic projection.
    • stereographic This mode is similar to fish-eye projection mode. The maximum field of view in this mode is 235°.

Landscape Tab

view_dialog_landscape_tab.png

The Landscape tab of the View window controls the landscape graphics (ground). To change the landscape graphics, select a landscape from the list on the left side of the window. A description of the landscape will be shown on the right.

Note that while landscape can include information about where the landscape graphics were taken (planet, longitude, latitude and altitude), this location does not have to be the same as the location selected in the Location window, although you can set up Stellarium such that selection of a new landscape will alter the location for you.

The controls at the bottom right of the window operate as follows:

  • Show ground This turns on and off landscape rendering (same as the button in the main tool-bar).
  • Show_fog This turns on and off rendering of a band of fog/haze along the horizon.
  • Use associated planet and position When enabled, selecting a new landscape will automatically update the observer location.
  • Use this landscape as default Selecting this option will save the landscape into the program configuration file so that the current landscape will be the one used when Stellarium starts.

Starlore Tab

view_dialog_starlore_tab.png

The Starlore tab of the View window controls what culture's constellations and bright star names will be used in the main display. Some cultures have constellation art (Western and Inuit), and the rest do not.

Personal tools
Namespaces
Variants
Actions
in this wiki
other languages
Toolbox